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Primus & SharpEye–nodescanning. 
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Materialet med billedfiler kan hentes på http://www.frborg-gymhf.dk/gj/Primus/
Du kan scanne en node direkte ind i SharpEye fra en papirudgave eller du kan åbne den fra et allerede indscannet billede af en node i tiff-format eller bmp-format. Hvis du har en scanner tilsluttet din computer er det smartest at scanne direkte, men hvis du ikke har det kan du altså også arbejde ud fra et scannet billede af noden. Fordelen ved det sidste er fx at du kan arbejde med programmet her uden at have en computer med eller du kan få andre til at scanne noder og sende dem til dig, og så selv arbejde videre med billedet. Nedenfor er der nogle eksempler på hvordan vi kan arbejde ud fra nodeeksempler vi allerede har scannet ind, men du kan sagtens prøve at løse opgaverne ved at scanne selv ud fra dette notesæt. Bagi står hvordan du henter en node ind i SharpEye vha scanner.
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Hent en node node og lyt til den:
Hvis du ikke har en scanner tilsluttet kan du hente et TIF-billede af en node ind i programmet uden en scanner (hvis du har en ven i Jylland, der scanner billedet til dig og sender det). Vi vil nu prøve at scanne følgende koral fra koralbogen:

· Vælg File>OpenImage (eller vælg knappen Open Image … se nedenfor) og vælg derefter HerKommerJesusDineSmaa.tif som du finder i SharpEye-mappen på CD’en 
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· Vælg Read Image (pilen) eller vælg i menuen Read>Read
· Når programmet er indlæst trykker du på Play og lytter til musikken. 

· Tryk på Save musicXML-file eller vælg File>MusicXML>Save as (eller Save), og gem filen under navnet HerKommer1
· Åben Primus og vælg Filer>Åben og find så filen HerKommer1.xml. 

· Tryk alt-1 og se de to stemmer og alt-2 og se de to andre. Tryk num 7 og se det hele.

Resultatet kan se lidt forskelligt ud, men måske ser dit resultat således ud – uden tekst og i to systemer. Bemærk at S og A ikke har samme rytme, hvorfor de bliver delt i to stemmer. Det samme gælder T og B:
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Hvad med teksten?
I udgaven ovenfor var teksten ikke med. Det var den muligvis i din udgave. Under alle omstændigheder ser vi på hvilke valg, der er afgørende for at teksten kommer med så godt som muligt.

· Vælg Options>Text recognition options. Her er valgene lidt sammensatte:
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· Tryk på Read igen (pilen). Vi får nu følgende forespørgsel:
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· Vi siger OK, fordi vi ikke har noget mod at få overskrevet den aflæsning af noderne. Vi håber på at kunne gøre det bedre.

Men resultatet bliver formodentlig ikke bedre vel? Stadig ingen tekst. Det der forvirrer, er, at teksten står over. 
For at rette på det skal vi ind og stille på hvordan programmet læser teksten. Vi skal være klar over at i en node står der mange forskellige typer tekst: sangtekster, akkorder, ord der siger noget om hvordan musikken skal spilles og ord der fortæller om hvem der har lavet musikken eller hvilken sammenhæng den skal bruges I. Det giver mange muligheder for forvekslinger. Det er derfor muligt at specificere hvad programmet skal lede efter og hvor det skal lede:

· Vælg Options>Text recognition options og vælg i feltet Look for lyrics at der skal være markeret for above staves.

· Sæt flueben i Assign lyrics to up-stem voice så teksten knyttes til den øverste stemme.

· Tryk nu på Read igen, og sig igen Ja til at få overskrevet.
· Når nodebilledet kommer frem trykker vi på SaveMusicXML-file (eller (File>MusicXML>Save as) og gemmer den som HerKommer2
· Åben Primus og åben filen. Nu skulle teksten gerne være med og stå mellem de to nodelinjer. Samtidig er der sneget sig et par fejl ind:
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· Klik på ordet Schulz i næstsidste takt. Når tekst boxen åbner sletter du ved at trykke på slet tilbage , der er den almindelige pil-tilbage-sletteknap. Bliv ved indtil der ikke er flere ord i den linje, der er forkerte. 

· Klik på ordet sma i 4.sidste takt og brug igen slet-tilbage så længe du kan.

· Klik på J i næstsidste takt og slet-baglæns

· Klik på esus i takt 5 og slet baglæns

Det færdige resultat bliver nu:
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… og det bliver vist ikke meget bedre.

Hvad med akkorder?
SharpEye kan også hente akkorder og læse partiturer. Lad os starte med et overskueligt eksempel:
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· Vælg Open Image File og vælg SaveMe2.tif
· Vælg Options>Text recognition options og vælg følgende indstilling:
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· Tryk på Read igen (pilen).
· Når nodebilledet kommer frem trykker vi på SaveMusicXML-file (eller (File>MusicXML>Save as) og gemmer den som SaveMe2
· Åben Primus og åben filen. Nu skulle akkorderne gerne være kommet med. Det eneste der ikke har fungeret har været trommerne:
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· Prøv at lytte til det. Der er klaver-lyd  på alle stemmerne og trommerne mangler noget og skal IKKE spilles på et klaver. 

· Vælg nu num 4 så du åbner mixeren. Tryk på Mute på kanal




· Lyt til satsen igen. Læg mærke til at instrumenterne nu giver et bedre lydbillede. Det passer dog stadig ikke rigtig fordi nogle af instrumenterne egentlig burde transponeres en oktav.

· Klik på el-bassens nøgle og udskift f-nøglen med en f-nøgle med et 8-tal under. Da dette ikke ændrer på tonerne men bare på noteringen af dem, vil de nu pludselig ligge en oktav højere.

· Sørg for at vi er i takt-mode (skift mode med ctrl+mellemrum) og dobbelt-klik i bassens første takt samtidig med at du holder ctrl nede. Derved bliver hele stemmen afmærket.

· Hold shift nede samtidig med du trykker på pil-ned. Derved flyttes stemmen en oktav ned.

· Lyt til den og kontroller at bassen er blevet dybere.

· Gør nu det samme med guitaren. Udskift nøglen med en g-nøgle med 8-tal under og afmærk hele stemmen og transponer en oktav ned med shift og pil-ned.
· Hvis du vil have trommestemmen med er det lettest at skrive den helt forfra. Start med hi-hatten/bækken. (Noden er lidt upræcis her: Er det hihat eller bækken? Svaret er vist nok lidt af hvert, hvis vi lytter til originalen. Vælg fx ridebækken). Skriv først bare rytmen. Hvis du ikke ved præcis hvor den ligger, gør det ikke noget. Det retter vi til bagefter. 
· Højre klik på 1-slaget og vælg Trommelyde. Vælg de lyde du ønsker fx Ridebækken 1 (husk også at klikke den lyd der allerede er valgt – her Åben Hi-hat væk … ellers får du begge).
· Stortromme/lilletromme skal noteres i samme nodelinje men i en anden stemme for at vi kan få lov til at lave en anden rytme. Tryk alt+2 eller tryk numerisk 2  og vælg stemme 2. 
· Tryk på numerisk 7 for at få vist alle stemmer på en gang

Nu mangler vi kun at kopiere denne trommerytme ud i de andre takter. Kontroller at vi er i Takt-modus. 
· Afmærk første takt ved ctrl+venstreklik
· Kopier 1. takt med bogstavet c (IKKE med ctrl+c som ellers er standard i Windows)

· Klik på takt 2.

· Gentag proceduren med at trykke c og klikke i næste takt. 
(Du kan også vælge at afmærke flere takter på en gang ved at holde ctrl nede og så trykke i første og sidste takt i den blok du vil kopiere. Nu vil C kopiere hele blokken og anbringe den fra den takt du klikker i.)
Arrangementer over flere sider.
Hvis du vil scanne en sang på flere sider, så skal du bare scanne alle siderne som billeder først. Vi har allerede en scannet udgave vi vil se på, så vi går bare i gang.
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De to noder ligger som CastleOnACloud1.TIF og CastleOnACloud2.TIF
· Gå til menuen Read > Batch process... vælg Add files … og vælg filen CastleOnACloud1.TIF
· Vælg derefter Add files … og vælg CastleOnACloud2.TIF. 
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· Bemærk feltet Output folder. Her står hvor den scannede fil kommer hen. Du kan sætte den til Skrivebord som jeg har gjort eller til noget andet.
· Bemærk feltet Name for joined file. Her står hvad den samlede fil kommer til at hedde. Programmet kalder den som udgangspunkt for AllPages. Det retter jeg til CastleSamlet
· Tryk på Start batch. Programmet læser nu musikken og gemmer den som filerne CastleOnACloud1.mro , CastleOnACloud2.mro og den samlede som CastleSamlet.mro. 
(Hvis du allerede har konverteret disse filer en gang, så får du en fejlmeddelelse om at du skal slette de filer af samme navn. Programmet tilbyder ikke at overskrive dem. Løsningen kan være at slette dem eller vælge nye undermapper at gemme outputtet i.)
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· Når du får en meddelelse om at konverteringen er i orden, går du til menuen File > Open music... og vælger filen CastleSamlet.mro (eller hvad du har kaldt den).
Vi får nu følgende advarsel, der skyldes at antal linjer i de forskellige nodesystemer ikke har passet sammen:
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· Vælg OK
Maksimer nodebilledet og kig på det, lyt til det. Det minder om noget vi har hørt før, men der er også diverse problemer:
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Bemærk at den tomme linjer er tilføjet nederst. Dvs at det iflg noden er ”klaver-bassen” der mangler i takt 1-2, men det er det ikke. Det er vokalen. Den fejl retter vi i SharpEye inden vi gemmer musikken:

· Tag fat i den pil, der peger fra 3. nodelinje i 1. system til 3. nodelinje i 2.system. Du skal tage fat i pilen, der hvor den peger på takt 3 og flyt den op til linje 1.

Nu skulle det gerne se sådan ud: [image: image16.png]AllPages * - SharpEye2 =18 x|
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· Gem nu filen som musicXML-fil.
· Åben filen i Primus og lyt til den. Der er ikke mange fejl. 
Vi retter tempoet 

Tempoet skal iflg noden være 66, men Primus har valt et tempo på 120. Det kan vi rette på forskellige måder. Den letteste er følgende:

· Vælg Midi>Spilmuligheder og vælg Grundtempo i feltet Tempo til 66.
En anden ”sjov” måde at gøre det på i stedet er følgende:

· Åben en tekstboks med Fri tekst
[image: image17.png]Tekststlat m ) [Tine on Fonen =1 wmj

Auer ntsat





· Klik på Tekststilart og vælg Tempo.
· Tryk på Node og vælg en ¼-delsnode, og fortsæt så der står 
 
· Nu er tempoet sænket!
Et sjovt problem!

Når vi ser på skærmbilledet er noget gråt og andet sort:
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Det skyldes det polyfone. SharpEye har set, at der er mere end en rytme i klaverets højrehånd, så derfor er satsen lagt i forskellige voices. Tryk på alt+1 for at se voice1 og på alt+2 for at se voice2.
· Lyt til takt 1-2. Hører du alle dele af klaver-satsen? Muligvis hører du kun 1/16-delene. 

· Prøv nu at åbne Midi og Spil-muligheder. 
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· Hvis der er flueben i feltet Dynamiske tegn under Hvilke symboler skal påvirke afspilning så prøv at fjerne det, tryk OK og lyt igen. Nu skal begge stemmer være lige kraftige. 

· Hvis der IKKE er flueben i dette felt, så prøv at sætte det og lytte til satsen igen. Så skulle der gerne være dele af klaversatsen der mangler.
Forklaringen er det lille pp vi har scannet ind fra billedet. SharpEye har læst det og valgt at knytte det til voice1.

· Åben Spilmuligheder igen og kontroller prøv at lytte til satsen både med akkorderne slået til og fra. Bemærk at Primus opfatter becifringen som akkorder endda med særlig bastone, de steder det er noteret i becifringen.
· Gå ind i Vis>Forkert taktlængde med gul farve. Er der steder hvor noderne ikke passer? Ret dem til 
Arrangementer med flere problemer.
I eksemplet er der en del udfordringer. Vi bemærker fx at der ikke er lige mange linjer i alle systemer idet koret ikke er med i det første system. Samtidig er hele layoutet præget af en vilje til at spare på ressourcerne, så nodebilledet er meget komprimeret.

Resultatet bliver et nodebillede der kræver nogle rettelser, men som stadigvæk sparer en for timers arbejde hvis alternativet er at skrive det hele selv. Lad os se på det.

Bemærk at billedet er scannet lidt skævt. Det kan give problemer, men det gør det ikke her:
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· Gå til menuen Read > Batch process... vælg Add files … og vælg filen beatles1.TIFF
· Vælg derefter Add files … og vælg beatles2.TIF. 
· Bemærk feltet Output folder. Her står hvor den scannede fil kommer hen. Du kan sætte den til Skrivebord som jeg har gjort eller til noget andet.
· Bemærk feltet Name for joined file. Her står hvad den samlede fil kommer til at hedde. Jeg har kaldt den EightDays
· Tryk på Start batch. Når du får en meddelelse om at konverteringen er i orden, går du til menuen File > Open music... og vælger filen EightDays.mro (eller hvad du har kaldt den).
· Vi får nu fen advarsel, der skyldes at antal linjer i de forskellige nodesystemer ikke har passet sammen. Vælg OK
Maksimer nodebilledet og kig på det, lyt til det. Det minder om noget vi har hørt før, men der er også diverse problemer. Det er klaveret vi hører i starten. 
· Tag fat i den pil, der peger fra 2. nodelinje i 1. system til 2. nodelinje i 2.system. Du skal tage fat i pilen, der hvor den peger på takt 5 og flyt den ned til den linje den skal fortsætte i nemlig 4. linje. Det er bassen.

· Tag den pil der går fra klaveret i 1. nodelinje i 1. system til 3. nodelinje i 2. system

Nu skulle det gerne se sådan ud:
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· Gem nu filen som musicXML-fil.
· Åben filen i Primus og lyt til den. Der er mange fejl men der er også rigtig mange ting der er kommet med. Lad os rette nogle af disse fejl nu.
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Ret akkorder til der er blevet til tekstbokse
· Start med at klikke der hvor fortegnene skal stå i øverste system. Det skal være mellem g-nøglen og taktangivelsen. Vælg to #’er i den menu, der åbner sig.
· Klik på den akkord der står i takt 2 og ret Eld til E/d.
· Tryk derefter Esc, så tekstboksen lukkes og højreklik så på akkordangivelsen og vælg Mache zu akkord. Bemærk at typografien ændres.
· Ret på samme måde Gld til G/d i næste takt.
Flyt tekstbokse op til den øverste linje
Det næste vi skal er at ordene Lennon-McCartney og Arr: Ejvind Dengsøe op på plads. Lad os først prøve hvordan vi ikke skal gøre det, for at se hvilke problemer det kan give. I får dem alligevel ind imellem, så man kan lige så godt forberede sig på dem. 

· Gem dokumentet inden du går i gang.
· Når du skal gå i gang med noget der kan gå galt er det en god ide at gemme det under et nyt navn. Det gør du ved at vælge Filer>Gem som og så give det navnet SlettesSnart. Nu har du en fil du kan rode med, og du kan altid gå tilbage til den gamle igen.

· Tag fat i Lennon-McCartney med venstre musetast og flyt det op på plads. Virker det? Nej. Når vi slipper kommer der bare et kæmpe hul mellem nodelinjerne. Det er fordi programmet ved at denne tekst står over 3. nodelinje og det er indstillet til ikke at skrive tingene oven i hinanden. Det er sådan set en god indstilling, men lige her giver det et pudsigt problem. 

· Løsningen på dette kan være at gå ind og slå denne mekanisme fra: Vælg Stykke>Systemafstande og fjern så fluebenet i feltet nederst under Kollisionshåndtering. Nu kan du flytte på det hele som du vil,  men du har samtidig overtaget ansvaret for at tingene ikke står oveni hinanden.

Løsningen ovenfor kan være god at kende, men generelt er det bedre at løse problemet uden at slå kollitionshåndtering fra, hvis man kan.

· Åben den fil du gemte før du gik i gang med at flytte på ordene.
· Venstreklik på tekstboksen Lennon-McCartney og vælg i den menu der åbner sig følgende: Skift type>Komponist

· Gør det samme med arr Dengsøe. Nu spørger programmet om det skal vedhæftes fordi der allerede er angivet noget om komponist og du siger Ja
· Venstreklik på tekstboksen Forspil, Efterspil og vælg Mache zu Takttext. Umiddelbart sker der ikke noget men hvis du venstreklikker et sted udenfor nodelinjerne hopper teksten op for oven, og du kan nu flytte den hen hvor du vil have den. 
Hvilke andre problemer er der? Nogle steder er rytmen noteret forkert. Et enkelt sted har nodelinjerne stået så tæt at programmet har læst en node i klaverets g-nøgle som hørende til f-nøglen, og så har den ikke fanget det med volterne. Lad os prøve at rette det. 
Vi retter volterne på plads
· For at tilføje volter i takt 21 og 22 højre-klikker du på taktstregen mellem dem og vælger Tilføj volteklammer 1. 2. Hvis den skal være længere kan du trække den med musen, men det skal den ikke være her.
· I 2. volte skal der egentlig stå 2. 3. og det retter du ved at klikke på totallet og skrive 3.tallet også.

· Skift til Horisontal visning ved at trykke F1, hvis Primus ikke allerede viser horisontal visning.

· Træk volten helt hen til takt 29 med ved at tage fat i højre ende af voltestregen og trække med musen.

· Højreklik på taktstregen før takt 30 og vælg Tilføj volteklammer 1.2.
· Ret nu tallet i volten til 4.
Der er en del rytmiske fejl og andre småfejl.
Nedenfor ser vi kort på nogle af de fejl der er. Hvordan man retter dem er standard redigering i Primus, og det vil vi henvise til begyndermanualen hvis du er i tvivl 

· For at finde de rytmiske fejl kan du vælge Vis>Forkert taktlængde med gul farve. Nu vil alle takter hvor der er rytmiske fejl i blive vist som gule.

· Prøv også at skifte mellem alt+1 og alt+2. Hvis SharpEye opdager at der er forskellige rytmer samtidig i samme nodelinje prøver den at splitte det op i forskellige voices. Det kan give nogle pudsige problemer.

· Egentlig er satsen i swing eller shufle. Sæt programmet til at spille svingende 1/8-dele under Midi>Spilmuligheder.

· Hvis det skal lyde rigtig skal bassen og klaveret en oktav ned (og skal have nye nøgler).

· Alle stemmerne spiller en Piano-lyd.

Fra Node til SharpEye vha scanner:
I det foregående har vi taget udgangspunkt i billeder af noderne i TIFF-format. Hvis du har en scanner tilsluttet, kan du prøve at scanne noder direkte. Det betyder at du scanner noderne som billeder fra SharpEye. Lav først disse indstillinger:
· Først skal du vælge hvor SharpEye skal scanne noderne. Det gør du ved at vælge menuen File > Select Twain source... vælges driveren til din scanner.

· For lettere at kunne se billedet af den node du scanner ind, kan du vælge menuen View > Zoom image > Small 25%
· I menuen Options > Text recognition options... sættes sprog og tegnsæt til "Danish". Her er andre valgmulidheder vi senere kommer tilbage til.

· (Gå til menuen Options > Save options... og gem dine indstillinger. Hvis du kan det.)

· Læg et nodeark i scanneren og lad os prøve at scanne noget ind.
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· Den første knap i ovenstående værktøjslinje starter scanningen.

· Når scanneren åbner skal du vælge følgende indstillingerne for scanneren: Du skal scanne i sort/hvid; det kan også hedde "tekstforbedring", "tekst", "line art", "monochrome". Du bør ikke scanne i farver eller gråtone. Opløsningen bør være mellem 300 og 400 dpi alt efter noderne størrelse. Små noder kan du scanne med ca. 400 dpi eller derover, mens lidt større noder kan scannes med 300 dpi. Prøv dig frem.

· Start scanningen med dit scanneprogram og scanningen går i gang. Når den er færdig kommer du automatisk tilbage til SharpEye, hvor du kan se det scannede billede.[image: image24.bmp][image: image25.bmp]






Fjern evt fluebenet hvis der ikke er tekst på nummeret.





Fil-typen musicXML minder om MIDI på den måde, at det er en fælles standard. Den håndterer bare flerstemmige elemter meget bedre end MIDI. Nodeprogrammer som Primus og ScorePerfect kan åbne musicXML-filer.  





Save MusicXML-file


























Open Image








De faste fortegn mangler





To af akkorderne er blevet tolket som tekstbokse





Read














Komponist og arrangør står midt i det hele





Vælg nye stemmer her ved at klikke.





Mute trommerne her.





Vi vil også læse akkorderne.





Teksten er på engelsk.





Akkorderne er over stavene.





Teksten er under stavene.





Hav altid flueben ved Danish her. Det betyder at danske tegn kan genkendes.





Play





Sæt flueben hvis tal også skal genkendes. Lad som udgangspunkt være med at sætte flueben her.





Vælg Danish hvis teksten er på dansk.





SharpEye er et nodescanneprogram, som kan bruges med alle nodeskrivningsprogrammer.�Programmet koster 1245 kr ( �HYPERLINK "http://www.indigo2.dk"�www.indigo2.dk� ), men du kan hente en prøveversion, som fungerer uden begrænsninger i 30 dage på �HYPERLINK "http://www.visiv.co.uk/installsharpeye2.exe"�www.visiv.co.uk/installsharpeye2.exe�
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